Database performance degradation

Incident Report for Tive

Resolved

All systems are now operating normally. No data has been lost, and data pipelines have fully recovered. We’ll continue to monitor, but normal operations have been restored.
Posted Oct 22, 2025 - 20:00 UTC

Monitoring

We’ve identified a database issue that caused delays in loading and processing data. We’re seeing signs of recovery and will continue monitoring until performance is fully back to normal and all data has been processed.
Posted Oct 22, 2025 - 15:39 UTC

Investigating

We’re currently investigating an issue related to database performance that’s preventing data from loading properly. Our team is actively working to restore normal operation as quickly as possible.
Posted Oct 22, 2025 - 15:09 UTC
This incident affected: Platform (Web Application, APIs, Report Generation) and Tracker Data Pipeline (Data Ingestion & Processing, Webhooks & Integrations, Alert Processing, Ocean & Air Data).